Page 1 of 1

Carrier 58RAV furnace won't run

PostPosted: Thu May 19, 2011 3:26 pm
by romans117
Hello All,

I can not get my furnace to run. The digital thermostat is blank but there is 24vac present. I tried jumping the red (Rh) wire to the green, yellow, white wires individually but nothing happens. I went to the furnace itself and and the LED was solid red. I jumped the "Test" post with the "24C" post and got the - one quick blink and one steady blink on the LED, indicating no fault codes. The furnace cycled through the test like it was suppose to, but I still get a blank thermostat and the furnace won't engage when jumping wires.

Help please!

- Carrier 58RAV furnace won't run

PostPosted: Sat May 21, 2011 8:55 pm
by 4ftBanger
Where do you have 24vac present? - Detected at the thermostat between R & C means the furnace is putting out low voltage and you don't have a safety or fuse open... - Jumper between R & G - blower should start - there might be a time delay of maybe 60 seconds before the motor starts. - (Same goes for the heat cycle when you jump R & W - internal delays on the board logic)

Check for low voltage at the furnace with jumpers attached at the thermostat - make sure wires aren't broken between the two. If you jump out terminals at the furnace and still don't get results you may have a safety switch open, stuck pressure switch, or a bad furnace control. Might be time to call a pro you trust.

*** Note - applying jumper wires to HVAC control terminals at the control board or at the thermostat may inadvertently short out the control circuit causing blown low voltage fuses, thermostat, or transformer damage. Please do not attempt to troubleshoot or repair your own equipment unless you feel comfortable with your understanding of the appliance.