Goodman sometimes wont open gas valve

Problems related to residential installations.

Goodman sometimes wont open gas valve

Postby Hersbird » Tue Jan 11, 2011 12:28 am

So I've been battling this for the last two winters. The furnace is about 7 years old and a GMT-115 on natural gas. It will start the draft motor fine and about 20 sec later the ignitor will glow and stay on for 10-20 secs. Then sometimes, about 40% lately, you will hear the gas valve click open and the furnace will ignite and run fine. Other times that gas valve never clicks open and the ignitor goes off and waits about 30 sec before trying again. It will do that 3 time and then if the gas valve never opens it goes into a 1 hour lockdown. Then it trys it all over again. Last night it must have locked up 2 or 3 times in a row as we lost about 9 degrees. If it only goes down for 1 hour we only lose 2 or 3 degrees when the temp outside is around 30. It did get down to 8 last night so maybe an hour off is all it takes to lose 9 degrees! Our home is old 1940's but updated with newer windows and insulation.

I did clean the flame sensor, and upgraded to the newer ignitor. So will a gas valve have intermittent problems like that or is it more likely the control board or transformer? I can try and check the voltage at the gas valve with a meter but do you check it when it's running connected, or do you disconnect the leads and check? Can the roll out switches have some internal problems that would cause this and if so how do you check them?
Sometimes it seems to go for weeks without a hitch, but lately it seems like 40% and I'm afraid it's going to stop alltogether.
Hersbird
Minimal
 
Posts: 1
Joined: Tue Jan 11, 2011 12:13 am

Return to Residential