Trane XR80 - open high limit device

Problems related to residential installations.

Trane XR80 - open high limit device

Postby otulp » Wed May 04, 2011 10:21 pm

Hello,

I have a Trane XR80 and have no heat. The led light blinks 4 times which indicates an open high limit device. How do I fix this?

1) I turn on heat
2) Draft Inducer motor starts
3) Led light blinks 4 times
4) Burners do not come on (doesn't ignite)

Other -
1) Filter is new
2) Blower motor appears to be working (It spins and air is moving, although not sure if it's weak or not.)
3) Burners do not come on even after turning off the power and then turning it back on. However, they do come on if I leave it off for a long time (like a week) and then turn it back on. Burner stays on for 30sec - 1 minutes then turns off.
4) High limit switch was replaced but problem remains
5) This also happened 6 months ago. The service technician said my furnace was dirty so he cleaned it and it worked for 6 months, but the issue has resurfaced. I change filters regularly and furnace does not appear to be clogged/dirty (although I have not taken the furnace apart to look inside the different chambers).

What can I do? Any help is appreciated. Thanks in advance!
otulp
Minimal
 
Posts: 1
Joined: Mon Apr 25, 2011 7:43 pm

- Trane XR80 - open high limit device

Postby aircooledtx » Thu May 05, 2011 9:03 am

Got an issue with either flue or heat exchanger cause the limit to go out,better call another company and ask for help..
aircooledtx
Most Valued Contributor
 
Posts: 46
Joined: Wed Apr 27, 2011 12:18 pm

- Trane XR80 - open high limit device

Postby cascadehvac » Mon May 09, 2011 4:49 pm

there are multiple hi-limits. you eed to get a tech im afraid
cascadehvac
Regular Contributor
 
Posts: 16
Joined: Wed Apr 27, 2011 10:24 am

- Trane XR80 - open high limit device

Postby A1TECK » Sun Nov 06, 2011 4:10 pm

I HAVE SAME UNIT SAM PROPLEM WHAT IS A LIMIT DEVICE AND GLOW BAR NOT GLOWING NO HEAT HELP CYCSENDIT@* SEND REPLY
A1TECK
New Contributor
 
Posts: 3
Joined: Sun Nov 06, 2011 2:08 pm

- Trane XR80 - open high limit device

Postby Freon » Mon Nov 07, 2011 11:31 am

If the burners do not come on then it is not the usual high limit switch since it would need burner heat to pass the error code. That being said, it might be a defective switch. The simplest way, if you're mechanically inclined and can read the schematic, is to jumper the high limit TEMPORARILY to be sure that's the problem. Is it possible you're reading the error code incorrectly? Besides the inducer starting, tell us if anything else happens. The more we know, the better the answers.
Freon
Most Valued Contributor
 
Posts: 734
Joined: Sat Jun 18, 2011 11:26 am


Return to Residential

cron