York Heat Pump

Problems related to residential installations.

York Heat Pump

Postby ijs » Thu May 05, 2011 3:56 am

Good Day,

My Heat Pump is not functioning and I am hoping someone can help. The unit is 7 years old and here are the system -

York Stellar Plus 12 Seer (Outdoor Unit Model E4FH042 Indoor Unit Model F2FP048)
Robertshaw 300-208 Thermostat

When I attempt to turn on both the heat or the air conditioning at the thermostat, the display goes blank then displays the letters "AC", followed by the 3 LED's at the top of the thermostat flashing once, then the thermostart resets back to its normal display of current temperature and mode. The heat pump nevers turns on during this time.
When I select to turn on the fan only at the thermostat, the fan in the indoor unit turns on normally.
When I select the Emergency Heat mode, the emergency heat turns on and functions normally.
This leads me to suspect my outdoor unit. I confirmed that the circuit breaker at the outdoor weather proof disconnect switch is not tripped, and that none of my other circuit breakers are tripped either. Also, the 5 amp fuse on the control circuit card on the indoor unit is good.
At this point I am at a loss. Any help would be greatly appreciated.
Thank you in advance.
ijs
Minimal
 
Posts: 1
Joined: Thu May 05, 2011 3:53 am

- York Heat Pump

Postby aircooledtx » Thu May 05, 2011 9:01 am

you have lost power to indoor unit, need to check your breaker panel.
aircooledtx
Most Valued Contributor
 
Posts: 46
Joined: Wed Apr 27, 2011 12:18 pm


Return to Residential

cron