E320 AC Not Working

An area where professionals can discuss HVAC /R related issues and topics.

E320 AC Not Working

Postby Dylan4234 » Mon Aug 29, 2011 10:12 am

My wife has a 2000 E320. We had a A/C hose concection leak which I fixed and refilled with R134a. Everything worked fine for a couple of days then the ac started acting up once again. There is no EC light on and the ac seems to work fine in the morning hours or when the car is first started in the morning. If you drive the car to work, cut it off and go back out in ten minutes or so, the ac will not work at that point. I did remove and clean the duovalves this morning to make sure this was not the problem. Everything worked good until she got back into the car a couple of hours later to go to work and no ac. I am sure it is a sensor somewhere, I just don't know where. Have seen a help topic in this one ****/parkland-air-duct-cleaning/* Air Duct Cleaning *** but was not supported. Any help will be appreciated. Oh yea if I don't get this fixed I'll be the one in HOT water!
Dylan4234
Minimal
 
Posts: 1
Joined: Mon Aug 29, 2011 10:03 am

- E320 AC Not Working

Postby heatseeker » Mon Aug 29, 2011 11:23 am

did you pull a vacuum on the system before recharging? did you change the metering device? iS THERE A FREON LEAK? have you fixed auto ac before? Mercedes are difficult to work on you might need a new compressor too. post back let me know the answers.
heatseeker
Most Valued Contributor
 
Posts: 542
Joined: Wed Jul 06, 2011 9:10 am

- E320 AC Not Working

Postby moshei » Wed Apr 04, 2012 4:53 am

Test the clutch coil first and it's bad.....Well, you need a new compressor..
Common reason is lack of freon...!
Thanks for sharing..!
moshei
Regular Contributor
 
Posts: 11
Joined: Wed Apr 04, 2012 4:15 am
Location: Manhattan, NYC

- E320 AC Not Working

Postby heatseeker » Mon Apr 09, 2012 11:51 am

Never ever touch a mercedes air conditioner if you are not a qualified tech, then even if you are good freaking luck.
heatseeker
Most Valued Contributor
 
Posts: 542
Joined: Wed Jul 06, 2011 9:10 am

- E320 AC Not Working

Postby heatseeker » Mon Apr 16, 2012 2:34 pm

what a freak
heatseeker
Most Valued Contributor
 
Posts: 542
Joined: Wed Jul 06, 2011 9:10 am


Return to Technicians Only