Need HELP!

General topics about all things heating, ventilation, air conditioning and refrigeration.

Need HELP!

Postby allmark » Fri Sep 30, 2011 5:59 pm

Our system is 5.5 years old. The AC stopped working 2 weeks ago. The technician came out and said the compressor was bad. The warranty will pay for the parts but not labor because we did not have it serviced last year. After the compressor was replaced they said the expansion valve was bad. That was replaced. He ran the system ran for 45 minutes and stopped working. Tech opened the blower portion of the unit. It had black mold covering most of it, all of the rivits are rusted and there is standing water in the system. When the system was installed (in 2006) it was winter- when we turned on the AC in May water flowed onto the floor. They said they installed the outflow pipe wrong and fixed it free of charge. The heaviest mold is where the the system had originally leaked. The owner of the company said he would come out and inspect- instead sent another tech. That tech told us the pipe could have been clogged and unclogged itself and we didn't know it. He went back and told the office the pipe was clogged and that is why there is water. He also took the insulation with all of the mold on it and I told them I wanted it back and now they cant find it. They agreed to replace the blower motor and module. WHen the tech tried to get the blower motor out it is rusted so badly they couldn't get it apart. They also found standing water underneath the blower unit (approx 2 inches). When I asked the office what we were going to do about the standing water and mold I was told that they were not responsible for any of it. She felt she (office rep) was being very nice seeing as I did not have the service done the last year and there was nothing they could do. We are at a loss as to how to deal with this. We are extremely concerned about the mold especially since myself and 2 kids have had horrible recurrent allergy/sinus problems. Most of our duct work is flexible and cannot be cleaned. We have told them that we need to talk to the owner at this point. He is out until mid next week. Any advice is greatly appreciated! Thanks in advance!
allmark
Minimal
 
Posts: 1
Joined: Fri Sep 30, 2011 5:38 pm

- Need HELP!

Postby juster » Sun Oct 02, 2011 4:59 pm

5.5 years old is not an old unit. You must get the water out of the unit and should consider having your ducts cleaned since the mold is already in the system.
Your evaporator pan is leaking into the bottom of the unit and not being directed away from the unit. There should be a hose connecting the AC evaporator coil to a drain of some sort. Try to find this line and make sure it is draining to the correct area (like a floor drain) and there is no blockages. If the line is blocked the water will over flow from the evaporator pan into the bottom of your unit. If you do not feel comfortable doing this, I would call another contractor ASAP before you cause further damage to your unit and your family.
Mold in your furnace or ducts is not good.
juster
Most Valued Contributor
 
Posts: 122
Joined: Tue Mar 30, 2010 7:40 am

- Need HELP!

Postby james88 » Sun Oct 02, 2011 9:48 pm

Your evaporator pan is unseaworthy into the depression of the object and not beingness directed inaccurate from the organization. There should be a garment connecting the AC evaporator mould to a drain of whatsoever sort. Try to mature this pedigree and alter reliable it is debilitating to the precise atlantic (like a room run) and there is no blockages. If the destination is obstructed the water testament over line from the evaporator pan into the freighter of your organization. If you do not conclude homy doing this, I would order another fascicle ASAP before you grounds further alteration to your thing and your family









***.*/seo-services/article-writing-and-submission.* ***
***.*/seo-services/article-writing-and-submission.* Article ***
james88
Minimal
 
Posts: 2
Joined: Sun Oct 02, 2011 9:35 pm

- Need HELP!

Postby heatseeker » Mon Oct 03, 2011 9:58 am

james 88 what????
heatseeker
Most Valued Contributor
 
Posts: 542
Joined: Wed Jul 06, 2011 9:10 am


Return to HVAC General Forum

cron