York TG9S Issues

Problems related to residential installations.

York TG9S Issues

Postby Sadist112 » Thu Dec 01, 2011 10:38 pm

Hi,

Just joined the forum for a little technical assistance. I have a York TG9S installed in April 2010. I just moved into the house in March 2011 so this is my first heating season (I live in Philly). My issue started with the ignitor lighting the burners and then the burners would go out after 5 seconds. After a few tries it ignites and goes on its business, until a limit switch trips, which it then goes through the entire cycle again. All the while the thermostat, which has new batteries, is calling for heat. Oh I i replaced the furnace filter a week ago...

So the first issue is obviously the Thermocouple... I cleaned that and also got a new one just in case, however the issue remains on start-up occasionally. So now the other issue the limit switch tripping...

Using a ohms meter I narrowed it down to one of the three limit switches. Then while doing that I realize the condensate collection unit is leaking, where is it leaking, directly on the limit switch and the Thermocouple.

See the attached videos I took a video, you can see the leak and the water dripping directly on the limit switch and the thermocouple. The second link below shows the "temporary" collection "unit" i made as a test to collect the water and direct it again from the Thermocouple and the limit switch.

Video - *.*/watch?*

Video - *.*/watch?*&*&*

To test this theory I increase the thermostate 5 degrees and it ran through the entire cycle without issues, so my assumption is the water leak is the issue.

I guess my question to the techs out there is has anyone every seen this? I am still covered under the warranty so I plan to call Johnson Controls tomorrow to fight for a new condensate collection unit. I say fight because I'm not a HVAC tech so I can only assume they are going to give me problems.

But I am still curious if anyone has ever seen this before?

Thanks in advance.
Sadist112
Minimal
 
Posts: 1
Joined: Thu Dec 01, 2011 10:19 pm

- York TG9S Issues

Postby how » Fri Dec 02, 2011 1:35 am

I was not able to download your videos but you shouldn't have a thermocoupler on a 2010 furnace. Many flame sensor lines have water permiable lines (god knows why?) that will ground out their dcmv current when wet and against bare metal. Limit controls will also ground out their ac volts through the screws that secure them to the furnace body.
Johnson controls will probably want to know what the flashing led diagnostic code is saying about your furnace but there is just no place for water and electronics to mix. Do you have a condensate pump or does it just gravity drain?
how
Most Valued Contributor
 
Posts: 87
Joined: Sun Nov 27, 2011 9:07 pm

- York TG9S Issues

Postby heatseeker » Fri Dec 02, 2011 12:21 pm

If it is under warranty then they need to troubleshoot it. Yes if water is leaking that is most definatly a problem. Probably the problem, I would not touch it for water and electricity can be very hazardous.
heatseeker
Most Valued Contributor
 
Posts: 542
Joined: Wed Jul 06, 2011 9:10 am

- York TG9S Issues

Postby Freon » Fri Dec 02, 2011 2:51 pm

"I am still covered under the warranty..." Call the installer. The installer is responsible. They should call Johnson controls and will probably get better results. However it seems the problem may be due to an installation problem. The installer needs to fix it, possibly with a new unit.
Freon
Most Valued Contributor
 
Posts: 735
Joined: Sat Jun 18, 2011 11:26 am


Return to Residential

cron