Lennox Control Board Issue?

An area where professionals can discuss HVAC /R related issues and topics.

Lennox Control Board Issue?

Postby Jonrob » Mon Jan 23, 2012 10:43 pm

Hi there,

Went to a service call Sunday evening to Lennox 90G... Furnace. As soon as stat calls for heat, induced draft motor comes on, however NO low voltage is being sent to any of my safeties or gas valve. Nothing at pressure switch, roll out... nothing. Almost instantly, control board clicks and turns my blower motor on, still no 24 V at anything, and the board tells me its normal operation. Transformer is fine, stats calling properly... all is good. Thus, changed board. Now, stat still calls and sends 24, blower motor comes on until delay finishes, and ventor motor does nothing. It came on once for a fluke 20 seconds, but even still none of my 24V controls were getting power, even when ventor motor comes on. Frustrating because Lennox doesn't do after hours tech help. Is it possible I got a bum control board out of the box, or do you have any suggestions?

Thanks a lot for the help.
Jonrob
Minimal
 
Posts: 1
Joined: Mon Jan 23, 2012 10:29 pm

- Lennox Control Board Issue?

Postby heatseeker » Tue Jan 24, 2012 4:10 pm

chances are you did or are doing something wrong. You could have damaged control board or maybe misplaced a wire trace thru it one wire at a time. How did you know the last circuit board was failed.?
heatseeker
Most Valued Contributor
 
Posts: 542
Joined: Wed Jul 06, 2011 9:10 am

- Lennox Control Board Issue?

Postby Big » Wed Mar 28, 2012 7:18 pm

Lennox has many problems with their boards , even the new ones.Get another board.
Big
Regular Contributor
 
Posts: 13
Joined: Wed Mar 28, 2012 7:07 pm


Return to Technicians Only

cron