Frigadaire furnace on LP model 80-90

Problems related to residential installations.

Frigadaire furnace on LP model 80-90

Postby bretty1110 » Sat Feb 11, 2012 3:28 pm

I have this furnace, i had some trouble already found that it needed a stage 2 reg, so thats in ,it goes threw the stages but when the furnace turns on , and the flame starts , the fan is blowing while its heating up the plemium ,its gets warm but not as hot as it should , i knw the blower is on low , somewhere or set to something , how do you reset or change the timer ? all i see are a set of jumpers ? or is this normal ?, i have a dim yellow light on the board meaning a ground , i was told i have to ground out the board or check my grounds ,i have no clue
bretty1110
New Contributor
 
Posts: 7
Joined: Thu Feb 02, 2012 3:11 pm

- Frigadaire furnace on LP model 80-90

Postby Silverjwj » Sat Feb 11, 2012 5:46 pm

I would get somebody to fix it who does have a clue!
Silverjwj
Most Valued Contributor
 
Posts: 28
Joined: Mon Dec 12, 2011 8:36 pm

- Frigadaire furnace on LP model 80-90

Postby how » Sun Feb 12, 2012 6:41 pm

What made you think that the 2 stage valve was the problem? Was it getting 24V on the upper stage before and not opening up?
That upper stage is controled by a timed board dip switch or by a compatable thermostat so you could have a board or thermostat problem.
The ground advise is unclear as the board should already be grounded but all modern furnace electronics depend on solid grounding to function. Check that your ground connections from the board all the way back to the house breaker are good.

A pro might cost but hopefully not in un nessesary parts.
how
Most Valued Contributor
 
Posts: 87
Joined: Sun Nov 27, 2011 9:07 pm


Return to Residential

cron