Lennox Comfortsense 7000 Touchscreen thermostat has blotches

Problems related to residential installations.

Lennox Comfortsense 7000 Touchscreen thermostat has blotches

Postby DFS » Sat Mar 17, 2012 3:50 pm

Hello. I have a strange problem and I'm trying to find out if others have seen this. I have a Lennox AC system and the screen on the stat went out so I had to buy a new one. I purchased a Lennox Comfortsense 7000 touchscreen model from an HVAC company online. After installing the stat I noticed that there are white blotches on the bottom of the screen. They look like the kind of thing you would see on a computer LCD monitor if you press on the screen. I contacted the seller and he gave me a replacement. The replacement does the SAME thing! I'm sure it is installed correctly. When I disconnected the old stat I wrote down which color wire was connected to each contact and made sure my wiring is solid and neat. The stat works just fine. It just these blotches. It's as though something is pressing on the back of the touchscreen. I even dismounted the stat from the wall to make sure the wasn't any pressure being applied from being screwed into the wall. Same thing. It must be on the inside of the unit because there is nothing behind the unit interfering with it. For what I paid for this thing I don't expect imperfections. I called Lennox and they were not helpful. They said to call in a service technician to look at it which is unacceptable. It will cost me as much for the service call as the cost of the thermostat. I am going to call the seller for help on Monday but wanted to see if anyone had an idea what's wrong. This should have been a no brainer. It has to be some sort of defect with these thermostats.

I took some pictures and a video if you would like to take a look. Thank you.

*.*/albums/zz50/dfs2010/Lennox%20Thermostat/
DFS
Minimal
 
Posts: 2
Joined: Sat Mar 17, 2012 3:20 pm

- Lennox Comfortsense 7000 Touchscreen thermostat has blot

Postby DFS » Sat Mar 17, 2012 4:19 pm

I see BBCode is off for me and * is being censored. I guess because I'm a new user?
DFS
Minimal
 
Posts: 2
Joined: Sat Mar 17, 2012 3:20 pm


Return to Residential