Trane Thermostat XT500C

General topics about all things heating, ventilation, air conditioning and refrigeration.

Trane Thermostat XT500C

Postby Lazarte » Wed Jul 04, 2012 7:55 am

hello i have a trane thermostat XT500C. Yesterday it started turning on and off. It would turn off for a few minutes then turn back on, says "wait" on screen then starts working again before it turns off again on its own. This cycle repeats constantly. There is obvious power going into the thermostat, I just do not know why it is doing this. Any help would be greatly appreciated.
Lazarte
New Contributor
 
Posts: 5
Joined: Wed Jul 04, 2012 7:51 am

- Trane Thermostat XT500C

Postby Lazarte » Wed Jul 04, 2012 8:28 am

Sorry I am completely ignorant on this. Did you mean batteries inside the thermostat?
Lazarte
New Contributor
 
Posts: 5
Joined: Wed Jul 04, 2012 7:51 am

- Trane Thermostat XT500C

Postby Lazarte » Wed Jul 04, 2012 8:41 am

I pulled the thermostat off the base and see no batteries or a slot for batteries inside.
Lazarte
New Contributor
 
Posts: 5
Joined: Wed Jul 04, 2012 7:51 am

- Trane Thermostat XT500C

Postby juster » Wed Jul 04, 2012 9:31 am

There are no batteries in this unit.
It has a capacitor that lasts 30 minutes. Programming functions are stored permanently.
It most likely has a loose wire. Check all wires on the back to ensure they are secure.
juster
Most Valued Contributor
 
Posts: 122
Joined: Tue Mar 30, 2010 7:40 am

- Trane Thermostat XT500C

Postby Lazarte » Wed Jul 04, 2012 11:19 am

where do i find this drain?
Lazarte
New Contributor
 
Posts: 5
Joined: Wed Jul 04, 2012 7:51 am

- Trane Thermostat XT500C

Postby Lazarte » Wed Jul 04, 2012 1:03 pm

the filter was changed about 8 months ago.
Lazarte
New Contributor
 
Posts: 5
Joined: Wed Jul 04, 2012 7:51 am

- Trane Thermostat XT500C

Postby wiskeygolf » Fri Jul 20, 2012 11:05 pm

I have the same problem that started today too. No the drain is not tripping the shutoff and i have switched thermostats with from other units and the thermostat works fine...no batteries in thermostat.

If i go outside and turn the main power swith off at the compressor and back on the power comes back to the thermostat and my AC runs for a few minutes and then POOF power goes out at the thermostat and the cycle repeats itself.

What besides the water trip valve will cut power to the thermostat? Why would the power come back to the thermostat after i recycle the on off switch?

Its driving me crazy because this must be a smiple problem but i cant figure it out!!!
wiskeygolf
Minimal
 
Posts: 2
Joined: Fri Jul 20, 2012 10:54 pm

- Trane Thermostat XT500C

Postby wiskeygolf » Sat Jul 21, 2012 9:07 am

I checked the drain shutoff and there was no water and the float switch was in the down position.

Funny thing is that after repeated resets of the outside circut breaker it has worked fine all night...Im thinking it might be a bad or going bad transformer ....why else would power be cut to the thermostat? Or could it be some type of high or low pressure issue which is automatically shutting down the system and when the pressure goes back to normal and it kicks back on?

Thanks in advance for your advise
wiskeygolf
Minimal
 
Posts: 2
Joined: Fri Jul 20, 2012 10:54 pm


Return to HVAC General Forum

cron