Connecting a Honeywell Humidity Controller...

Problems related to residential installations.

Connecting a Honeywell Humidity Controller...

Postby e070924batsona » Wed Jul 03, 2013 2:04 pm

Greetings;

I've purchased a Honeywell humidity Controller (I don't have the model number with me), but it handles 120/240VAC as well as low-voltage (24v). it's simply a box that shorts two wires on humidity rise, and opens on humidity drop. The technical docs on my TWE-E air handler (variable speed) (American Standard from 2006) indicate that it should be installed between "R" ad "BK" after the jumper is removed. Second, "R" and "O" should be shorted for cooling-only system, which is what I have -- no heat. This is exactly how I have it set up. However, regardless of whether the humidity controller is at 90% or 10%, the behaviour of the AH is completely unchanged. No change in fan speed, compressor doesn't come up -- nothing.

What is "supposed" to happen when R and BK are shorted together by the Humidity Controller?

Thanks!

Alex
e070924batsona
Minimal
 
Posts: 2
Joined: Mon Jul 01, 2013 2:24 pm

- Connecting a Honeywell Humidity Controller...

Postby e070924batsona » Fri Jul 05, 2013 12:38 pm

A pro on another board told me that O and Y should be shorted, not R and O. I've done this, but my AH doesn't behave any differently. The blower doesn't slow down if there's a call for cooling, and if the system is off, and there's a call to dehumidify (R and BK short) nothing happens at all. I'm thnking it's because of the way I have the blower DIP switches set...? I've got "Comfort-R" enabled right now. --I guess I should try other settings?
e070924batsona
Minimal
 
Posts: 2
Joined: Mon Jul 01, 2013 2:24 pm


Return to Residential

cron